blob: 2719811ce44275cc20bd9faa9417968acc6b99a6 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Capture::Tiny - Capture STDOUT and STDERR from Perl, XS or external programs."
2DESCRIPTION = "Capture::Tiny provies a simple, portable way to capture \
3almost anything sent to STDOUT or STDERR, regardless of whether it comes \
4from Perl, from XS code or from an external program. Optionally, output can \
5be teed so that it is captured while being passed through to the original \
6filehandles. Yes, it even works on Windows (usually). Stop guessing which of \
7a dozen capturing modules to use in any particular situation and just use \
8this one."
9SECTION = "libs"
10
11HOMEPAGE = "http://search.cpan.org/~dagolden/Capture-Tiny/"
12
13LICENSE = "Artistic-1.0 | GPL-1.0+"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=37a4918a30ace24395020e5b8c03b83f"
15
16SRCNAME = "Capture-Tiny"
17SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DAGOLDEN/${SRCNAME}-${PV}.tar.gz"
18SRC_URI[md5sum] = "d718af07729d26a793949ca6ba2580a7"
19SRC_URI[sha256sum] = "5d7a6a830cf7f2b2960bf8b8afaac16a537ede64f3023827acea5bd24ca77015"
20
21S = "${WORKDIR}/${SRCNAME}-${PV}"
22
23inherit cpan
24
25RDEPENDS_${PN} = " perl-module-scalar-util \
26 perl-module-io-file \
27 perl-module-extutils-makemaker \
28 perl-module-file-spec \
29 perl-module-exporter \
30 perl-module-carp \
31 perl-module-test-more \
32 perl-module-file-temp \
33 perl-module-lib \
34 perl-module-overloading \
35"
36
37BBCLASSEXTEND = "native"