blob: bca7757ad800012d2ae337ca61269c428248c304 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python. "
2HOMEPAGE = "https://www.h5py.org/"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=107;endline=107;md5=795ecad0d261c998cc526c84a822dff6"
6
7SRC_URI = "git://github.com/h5py/h5py.git \
8 file://0001-cross-compiling-support.patch \
9 "
10SRCREV ?= "8d96a14c3508de1bde77aec5db302e478dc5dbc4"
11
12inherit setuptools3
13
14S = "${WORKDIR}/git"
15
16BBCLASSEXTEND = "native"
17
18DEPENDS = "python3-pkgconfig-native \
19 python3-cython-native \
20 python3-numpy-native \
21 python3-six-native \
22 python3 \
23 hdf5 \
24 "
25
26RDEPENDS_${PN} = "python3-numpy \
27 python3-six \
28 "
29
30export HDF5_VERSION="1.8.19"