blob: 2ea810327d781fdf98797ef2d5d21746396c2f2e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "GUI tool for storage configuration using blivet library"
2HOMEPAGE = "https://github.com/rhinstaller/blivet-gui"
3LICENSE = "GPLv2+"
4SECTION = "devel/python"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8S = "${WORKDIR}/git"
9B = "${S}"
10
11SRCREV = "67ec0b7a0e065ba24ab87963409bfb21b2aac6dd"
12SRC_URI = "git://github.com/rhinstaller/blivet-gui;branch=master \
13"
14
15inherit distro_features_check
16REQUIRED_DISTRO_FEATURES = "x11 systemd"
17
18inherit setuptools3 python3native
19
20RDEPENDS_${PN} = "python3-pygobject python3 \
21 python3-blivet gtk+3 \
22 python3-pid libreport \
23"
24
25FILES_${PN} += " \
26 ${datadir}/* \
27 "