blob: 41ffd625cbd0da733c58d8c9ff50c6d1587820cd [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
7SRCREV = "4d64011741375bb1a4ba7d71905ca37b97885083"
8
9SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.4 \
10 file://run-ptest \
11"
12
13S = "${WORKDIR}/git"
14
15inherit autotools-brokensep pkgconfig ptest
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
19
20do_compile_ptest() {
21 oe_runmake -C tests check-build
22}
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 install -d ${D}${PTEST_PATH}/tools
27 for file in $(find tests/* -executable -type f); do
28 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
29 done
30 for file in $(find tests/*.tests -type f); do
31 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
32 done
33 for file in $(find tools/* -executable -type f); do
34 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
35 done
36}
37
38FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*"
39FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
40
41RDEPENDS_${PN}-ptest = "bash"