blob: 7aaf26aed12b0a4c1be83eacdab2cc091c38535f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001BUILD_GOOS = "${@go_map_os(d.getVar('BUILD_OS'), d)}"
2BUILD_GOARCH = "${@go_map_arch(d.getVar('BUILD_ARCH'), d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003BUILD_GOTUPLE = "${BUILD_GOOS}_${BUILD_GOARCH}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05004HOST_GOOS = "${@go_map_os(d.getVar('HOST_OS'), d)}"
5HOST_GOARCH = "${@go_map_arch(d.getVar('HOST_ARCH'), d)}"
6HOST_GOARM = "${@go_map_arm(d.getVar('HOST_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
7HOST_GO386 = "${@go_map_386(d.getVar('HOST_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
Brad Bishop316dfdd2018-06-25 12:45:53 -04008HOST_GOMIPS = "${@go_map_mips(d.getVar('HOST_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009HOST_GOTUPLE = "${HOST_GOOS}_${HOST_GOARCH}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010TARGET_GOOS = "${@go_map_os(d.getVar('TARGET_OS'), d)}"
11TARGET_GOARCH = "${@go_map_arch(d.getVar('TARGET_ARCH'), d)}"
12TARGET_GOARM = "${@go_map_arm(d.getVar('TARGET_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
13TARGET_GO386 = "${@go_map_386(d.getVar('TARGET_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040014TARGET_GOMIPS = "${@go_map_mips(d.getVar('TARGET_ARCH'), d.getVar('TUNE_FEATURES'), d)}"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015TARGET_GOTUPLE = "${TARGET_GOOS}_${TARGET_GOARCH}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016GO_BUILD_BINDIR = "${@['bin/${HOST_GOTUPLE}','bin'][d.getVar('BUILD_GOTUPLE') == d.getVar('HOST_GOTUPLE')]}"
17
18# Go supports dynamic linking on a limited set of architectures.
19# See the supportsDynlink function in go/src/cmd/compile/internal/gc/main.go
20GO_DYNLINK = ""
21GO_DYNLINK_arm = "1"
22GO_DYNLINK_aarch64 = "1"
23GO_DYNLINK_x86 = "1"
24GO_DYNLINK_x86-64 = "1"
25GO_DYNLINK_powerpc64 = "1"
26GO_DYNLINK_class-native = ""
Brad Bishop316dfdd2018-06-25 12:45:53 -040027GO_DYNLINK_class-nativesdk = ""
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028
29# define here because everybody inherits this class
30#
31COMPATIBLE_HOST_linux-gnux32 = "null"
32COMPATIBLE_HOST_linux-muslx32 = "null"
33COMPATIBLE_HOST_powerpc = "null"
34COMPATIBLE_HOST_powerpc64 = "null"
35COMPATIBLE_HOST_mipsarchn32 = "null"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036
37ARM_INSTRUCTION_SET_armv4 = "arm"
38ARM_INSTRUCTION_SET_armv5 = "arm"
39ARM_INSTRUCTION_SET_armv6 = "arm"
40
Brad Bishopd7bf8c12018-02-25 22:55:05 -050041TUNE_CCARGS_remove = "-march=mips32r2"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042SECURITY_CFLAGS_mipsarch = "${SECURITY_NOPIE_CFLAGS}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040043SECURITY_NOPIE_CFLAGS ??= ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050044
Brad Bishop19323692019-04-05 15:28:33 -040045# go can't be built with ccache:
46# gcc: fatal error: no input files
47CCACHE_DISABLE ?= "1"
48
Brad Bishop6e60e8b2018-02-01 10:27:11 -050049def go_map_arch(a, d):
50 import re
51 if re.match('i.86', a):
52 return '386'
53 elif a == 'x86_64':
54 return 'amd64'
55 elif re.match('arm.*', a):
56 return 'arm'
57 elif re.match('aarch64.*', a):
58 return 'arm64'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050059 elif re.match('mips64el.*', a):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050060 return 'mips64le'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050061 elif re.match('mips64.*', a):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050062 return 'mips64'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050063 elif a == 'mips':
Brad Bishop6e60e8b2018-02-01 10:27:11 -050064 return 'mips'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050065 elif a == 'mipsel':
66 return 'mipsle'
Brad Bishop6e60e8b2018-02-01 10:27:11 -050067 elif re.match('p(pc|owerpc)(64)', a):
68 return 'ppc64'
69 elif re.match('p(pc|owerpc)(64el)', a):
70 return 'ppc64le'
Brad Bishop19323692019-04-05 15:28:33 -040071 elif a == 'riscv64':
72 return 'riscv64'
Brad Bishop6e60e8b2018-02-01 10:27:11 -050073 else:
Brad Bishop316dfdd2018-06-25 12:45:53 -040074 raise bb.parse.SkipRecipe("Unsupported CPU architecture: %s" % a)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050075
76def go_map_arm(a, f, d):
77 import re
78 if re.match('arm.*', a):
79 if 'armv7' in f:
80 return '7'
81 elif 'armv6' in f:
82 return '6'
Brad Bishopd7bf8c12018-02-25 22:55:05 -050083 elif 'armv5' in f:
84 return '5'
85 return ''
86
87def go_map_386(a, f, d):
88 import re
89 if re.match('i.86', a):
90 if ('core2' in f) or ('corei7' in f):
91 return 'sse2'
92 else:
93 return '387'
Brad Bishop6e60e8b2018-02-01 10:27:11 -050094 return ''
95
Brad Bishop316dfdd2018-06-25 12:45:53 -040096def go_map_mips(a, f, d):
97 import re
98 if a == 'mips' or a == 'mipsel':
99 if 'fpu-hard' in f:
100 return 'hardfloat'
101 else:
102 return 'softfloat'
103 return ''
104
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500105def go_map_os(o, d):
106 if o.startswith('linux'):
107 return 'linux'
108 return o
109
110