blob: 707d74d1083854a0eb08a4d47c1d84d11371c8e5 [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# Helper class to pull in the right gtk-doc dependencies and configure
2# gtk-doc to enable or disable documentation building (which requries the
3# use of usermode qemu).
4
5# This variable is set to True if api-documentation is in
6# DISTRO_FEATURES and qemu-usermode is in MACHINE_FEATURES, and False otherwise.
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007#
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008# It should be used in recipes to determine whether gtk-doc based documentation should be built,
9# so that qemu use can be avoided when necessary.
10GTKDOC_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', \
11 bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d), 'False', d)}"
12
13EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-gtk-doc --enable-gtk-doc-html --disable-gtk-doc-pdf', \
14 '--disable-gtk-doc', d)} "
15
16# When building native recipes, disable gtkdoc, as it is not necessary,
17# pulls in additional dependencies, and makes build times longer
18EXTRA_OECONF_prepend_class-native = "--disable-gtk-doc "
19EXTRA_OECONF_prepend_class-nativesdk = "--disable-gtk-doc "
20
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021# Even though gtkdoc is disabled on -native, gtk-doc package is still
22# needed for m4 macros.
Brad Bishop316dfdd2018-06-25 12:45:53 -040023DEPENDS_append = " gtk-doc-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
25# The documentation directory, where the infrastructure will be copied.
26# gtkdocize has a default of "." so to handle out-of-tree builds set this to $S.
27GTKDOC_DOCDIR ?= "${S}"
28
Patrick Williamsc0f7c042017-02-23 20:41:17 -060029export STAGING_DIR_HOST
30
Brad Bishop316dfdd2018-06-25 12:45:53 -040031inherit python3native pkgconfig qemu
32DEPENDS_append = "${@' qemu-native' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060033
Brad Bishop316dfdd2018-06-25 12:45:53 -040034do_configure_prepend () {
35 # Need to use ||true as this is only needed if configure.ac both exists
36 # and uses GTK_DOC_CHECK.
37 gtkdocize --srcdir ${S} --docdir ${GTKDOC_DOCDIR} || true
38}
39
40do_compile_prepend_class-target () {
41 if [ ${GTKDOC_ENABLED} = True ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -060042 # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it
43 # can run target helper binaries through that.
Brad Bishop19323692019-04-05 15:28:33 -040044 qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\\$GIR_EXTRA_LIBS_PATH','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060045 cat > ${B}/gtkdoc-qemuwrapper << EOF
46#!/bin/sh
47# Use a modules directory which doesn't exist so we don't load random things
48# which may then get deleted (or their dependencies) and potentially segfault
49export GIO_MODULE_DIR=${STAGING_LIBDIR}/gio/modules-dummy
50
Brad Bishopd7bf8c12018-02-25 22:55:05 -050051GIR_EXTRA_LIBS_PATH=\`find ${B} -name *.so -printf "%h\n"|sort|uniq| tr '\n' ':'\`\$GIR_EXTRA_LIBS_PATH
Patrick Williamsc0f7c042017-02-23 20:41:17 -060052GIR_EXTRA_LIBS_PATH=\`find ${B} -name .libs| tr '\n' ':'\`\$GIR_EXTRA_LIBS_PATH
53
Brad Bishop19323692019-04-05 15:28:33 -040054# meson sets this wrongly (only to libs in build-dir), qemu-wrapper_cmdline() and GIR_EXTRA_LIBS_PATH take care of it properly
55unset LD_LIBRARY_PATH
56
Brad Bishop6e60e8b2018-02-01 10:27:11 -050057if [ -d ".libs" ]; then
Patrick Williamsc0f7c042017-02-23 20:41:17 -060058 $qemu_binary ".libs/\$@"
59else
60 $qemu_binary "\$@"
61fi
62
63if [ \$? -ne 0 ]; then
64 echo "If the above error message is about missing .so libraries, then setting up GIR_EXTRA_LIBS_PATH in the recipe should help."
65 echo "(typically like this: GIR_EXTRA_LIBS_PATH=\"$""{B}/something/.libs\" )"
66 exit 1
67fi
68EOF
69 chmod +x ${B}/gtkdoc-qemuwrapper
Brad Bishop316dfdd2018-06-25 12:45:53 -040070 fi
Patrick Williamsc0f7c042017-02-23 20:41:17 -060071}