blob: f3190e1cae002934472f320c7ad74dfd6ca1c450 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
8
9SECTION = "libs"
10DEPENDS = "glib-2.0"
11
12SRC_URI[archive.md5sum] = "75b14b7e73a67753be9ce307751c661d"
13SRC_URI[archive.sha256sum] = "bdfa0255e031b8ee003cc283002536b77ee76450105f1dc6ab066b9bf4330068"
14
15PACKAGECONFIG ??= "gnutls"
16
17PACKAGECONFIG[gnutls] = "-Dgnutls=true,-Dgnutls=false,gnutls"
18PACKAGECONFIG[libproxy] = "-Dlibproxy_support=true,-Dlibproxy_support=false,libproxy"
19
20EXTRA_OEMESON = "-Dgnome_proxy_support=false"
21
22GNOMEBASEBUILDCLASS = "meson"
23inherit gnomebase gettext upstream-version-is-even gio-module-cache
24
25FILES_${PN} += "\
26 ${libdir}/gio/modules/libgio*.so \
27 ${datadir}/dbus-1/services/ \
28 ${systemd_user_unitdir} \
29 "
30FILES_${PN}-dev += "${libdir}/gio/modules/libgio*.la"
31FILES_${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"