blob: 8bc7cd649b372bfc8770cbcef276f14750aa5161 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=cfc0ed77a9f62fa62eded042ebe31d72 \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11# Tell autotools that we're working in the localedef directory
12#
13AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
14
15inherit native
16inherit autotools
17
18FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
19
20SRCBRANCH ?= "release/${PV}/master"
21GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.(?!90)\d+)*)"
23
24PV = "2.29"
25
26SRCREV_glibc ?= "86013ef5cea322b8f4b9c22f230c22cce369e947"
27SRCREV_localedef ?= "cd9f958c4c94a638fa7b2b4e21627364f1a1a655"
28
29SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
30 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
31 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
32 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
33 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
34 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
35 file://0020-eglibc-Clear-cache-lines-on-ppc8xx.patch \
36 file://0021-eglibc-Resolve-__fpscr_values-on-SH4.patch \
37 file://0022-eglibc-Forward-port-cross-locale-generation-support.patch \
38 file://0023-Define-DUMMY_LOCALE_T-if-not-defined.patch \
39 file://0024-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
40"
41# Makes for a rather long rev (22 characters), but...
42#
43SRCREV_FORMAT = "glibc_localedef"
44
45S = "${WORKDIR}/git"
46
47EXTRA_OECONF = "--with-glibc=${S}"
48CFLAGS += "-fgnu89-inline -std=gnu99 -DIS_IN\(x\)='0'"
49
50do_install() {
51 install -d ${D}${bindir}
52 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
53}