blob: 3b9af6d739a8b5d3dba03b38c77296b3549ef704 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Extended cryptographic library (from glibc)"
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=be275bc7f91642efe7709a8ae7a1433b \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools pkgconfig
11
12PV = "4.4.2"
13# v4.4.2
14SRCREV ?= "cf6abf18083566ec1612af27982a5160c9e0f137"
15SRCBRANCH ?= "develop"
16
17SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH} \
18 "
19
20PROVIDES = "virtual/crypt"
21
22FILES_${PN} = "${libdir}/libcrypt*.so.* ${libdir}/libcrypt-*.so ${libdir}/libowcrypt*.so.* ${libdir}/libowcrypt-*.so"
23
24S = "${WORKDIR}/git"
25
26BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE} -std=gnu99"
27TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
28CPPFLAGS_append_class-nativesdk = " -Wno-error=missing-attributes"
29
30BBCLASSEXTEND = "nativesdk"