blob: 3647232dc68f1d9e553e5085f7277c0b99b0b955 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067"
12SECTION = "base"
13DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native"
14DEPENDS_append_class-target = " udev"
15RDEPENDS_${PN} = "libgcc"
16
17SRCREV = "6c33832b8c7bf2d7b64d6aed023c0bda43a03311"
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \
19 file://0001-Add-LDFLAGS-when-building-libbtrfsutil.so.patch \
20 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
21 "
22
23inherit autotools-brokensep pkgconfig manpages distutils3-base
24
25CLEANBROKEN = "1"
26
27PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native"
28EXTRA_OECONF = " --disable-zstd"
29EXTRA_OECONF_append_libc-musl = " --disable-backtrace "
30EXTRA_OEMAKE = "V=1"
31
32do_configure_prepend() {
33 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
34 mkdir -p ${S}/config
35 cp -f $(automake --print-libdir)/install-sh ${S}/config/
36}
37
38S = "${WORKDIR}/git"
39
40do_install_append() {
41 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
42}
43
44BBCLASSEXTEND = "native"