Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SUMMARY = "C Library for manipulating module metadata files" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=25a3927bff3ee4f5b21bcb0ed3fcd6bb" |
| 4 | |
| 5 | SRC_URI = "git://github.com/fedora-modularity/libmodulemd;protocol=https \ |
| 6 | file://0001-spec_tmpl.sh-use-bin-sh-not-usr-bin-sh.patch \ |
| 7 | file://0002-modulemd-v1-meson.build-do-not-generate-gir-or-gtkdo.patch \ |
| 8 | " |
| 9 | |
| 10 | PV = "2.1.0" |
| 11 | SRCREV = "072e6ee791fe7822a6d423bdac7e4a5cbb118bce" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit meson gobject-introspection |
| 16 | |
| 17 | EXTRA_OEMESON = "-Ddeveloper_build=false -Dbuild_api_v1=true -Dbuild_api_v2=false" |
| 18 | |
| 19 | DEPENDS += "glib-2.0 libyaml glib-2.0-native" |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |
| 22 | |
| 23 | GI_ENABLE_FLAG = "-Dskip_introspection=false" |
| 24 | GI_DISABLE_FLAG = "-Dskip_introspection=true" |
| 25 | |
| 26 | EXTRA_OEMESON_append_class-nativesdk = " ${GI_DISABLE_FLAG}" |
| 27 | EXTRA_OEMESON_append_class-native = " ${GI_DISABLE_FLAG}" |
| 28 | |
| 29 | EXTRA_OEMESON_append_class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GI_ENABLE_FLAG}', \ |
| 30 | '${GI_DISABLE_FLAG}', d)} " |