blob: a2329d3e710cd0d8d4b547bb82f137ecd5b4b06b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0"
9
10DEPENDS = "libarchive"
11
12PE = "1"
13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg.conf \
16 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
17 file://0001-libopkg-add-add-ignore-recommends-option.patch \
18"
19
20SRC_URI[md5sum] = "ae51d95fee599bb4dce08453529158f5"
21SRC_URI[sha256sum] = "f6c00515d8a2ad8f6742a8e73830315d1983ed0459cba77c4d656cfc9e7fe6fe"
22
23inherit autotools pkgconfig systemd
24
25target_localstatedir := "${localstatedir}"
26OPKGLIBDIR = "${target_localstatedir}/lib"
27
28PACKAGECONFIG ??= "libsolv"
29
30PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg"
31PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
32PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
33PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
34PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
35PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder"
36PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
37
38EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
39
40do_install_append () {
41 install -d ${D}${sysconfdir}/opkg
42 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
43 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
44
45 # We need to create the lock directory
46 install -d ${D}${OPKGLIBDIR}/opkg
47}
48
49RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
50RDEPENDS_${PN}_class-native = ""
51RDEPENDS_${PN}_class-nativesdk = ""
52RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
53RCONFLICTS_${PN} = "opkg-collateral"
54RPROVIDES_${PN} = "opkg-collateral"
55
56PACKAGES =+ "libopkg"
57
58FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
59
60BBCLASSEXTEND = "native nativesdk"
61
62CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"