blob: 5bf528bec1246b2a59d0affc91fe2e73f49f9d99 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001BPN = "qemu"
2
3require qemu-native.inc
4
5# As some of the files installed by qemu-native and qemu-system-native
6# are the same, we depend on qemu-native to get the full installation set
7# and avoid file clashes
8DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native"
9
10EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
11
12PACKAGECONFIG ??= "fdt alsa kvm"
13
14# Handle distros such as CentOS 5 32-bit that do not have kvm support
15PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
16
17do_install_append() {
18 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
19
20 # The following is also installed by qemu-native
21 rm -f ${D}${datadir}/qemu/trace-events-all
22 rm -rf ${D}${datadir}/qemu/keymaps
23}