blob: 704a3ecd0602e586332f2bc03633462c0a2187f3 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
9
10SRC_URI[md5sum] = "05d0718a1b7cc706a4bdf8115363f1ed"
11SRC_URI[sha256sum] = "b960541c499619efd6afe1fa795402e4733c8e11ebf9fafccc0bb4bccdc5b514"
12
13inherit autotools gettext texinfo pkgconfig
14
15# Fix "Argument list too long" error when len(TMPDIR) = 410
16acpaths = "-I ./m4"
17
18do_configure_prepend () {
19 rm -f ${S}/m4/init.m4
20}
21
22do_install () {
23 autotools_do_install
24 if [ "${base_bindir}" != "${bindir}" ]; then
25 install -d ${D}${base_bindir}
26 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
27 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
28 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
29 rmdir ${D}${bindir}/
30 fi
31}
32
33inherit update-alternatives
34
35PACKAGECONFIG ??= "pcre"
36PACKAGECONFIG[pcre] = "--enable-perl-regexp,--disable-perl-regexp,libpcre"
37
38ALTERNATIVE_PRIORITY = "100"
39
40ALTERNATIVE_${PN} = "grep egrep fgrep"
41ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
42ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
43ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"
44
45export CONFIG_SHELL="/bin/sh"