Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame^] | 1 | SUMMARY = "Utility for viewing/manipulating IDE disk drive/driver parameters" |
| 2 | HOMEPAGE = "http://sourceforge.net/projects/hdparm/" |
| 3 | DESCRIPTION = "hdparm is a Linux shell utility for viewing \ |
| 4 | and manipulating various IDE drive and driver parameters." |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | LICENSE = "BSD & GPLv2" |
| 8 | LICENSE_${PN} = "BSD" |
| 9 | LICENSE_${PN}-dbg = "BSD" |
| 10 | LICENSE_wiper = "GPLv2" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=495d03e50dc6c89d6a30107ab0df5b03 \ |
| 13 | file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \ |
| 14 | file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \ |
| 15 | file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09" |
| 16 | |
| 17 | |
| 18 | PACKAGES =+ "wiper" |
| 19 | |
| 20 | FILES_wiper = "${bindir}/wiper.sh" |
| 21 | |
| 22 | RDEPENDS_wiper = "bash gawk coreutils" |
| 23 | |
| 24 | SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/${BP}.tar.gz \ |
| 25 | file://wiper.sh-fix-stat-path.patch \ |
| 26 | " |
| 27 | |
| 28 | SRC_URI[md5sum] = "4652c49cf096a64683c05f54b4fa4679" |
| 29 | SRC_URI[sha256sum] = "9ae78e883f3ce071d32ee0f1b9a2845a634fc4dd94a434e653fdbef551c5e10f" |
| 30 | |
| 31 | EXTRA_OEMAKE = 'STRIP="echo" LDFLAGS="${LDFLAGS}"' |
| 32 | |
| 33 | inherit update-alternatives |
| 34 | |
| 35 | ALTERNATIVE_${PN} = "hdparm" |
| 36 | ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm" |
| 37 | ALTERNATIVE_PRIORITY = "100" |
| 38 | |
| 39 | do_install () { |
| 40 | install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir} |
| 41 | oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install |
| 42 | cp ${S}/wiper/wiper.sh ${D}/${bindir} |
| 43 | } |