blob: bb1618f1eb52db1e0c75ceda00530c4a1aa7abd5 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Text file viewer similar to more"
2DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
3based program for viewing text files and the output from other \
4programs. Less offers many features beyond those that more does."
5HOMEPAGE = "http://www.greenwoodsoftware.com/"
6SECTION = "console/utils"
7
8# (GPLv2+ (<< 418), GPLv3+ (>= 418)) | less
9# Including email author giving permissing to use BSD
10#
11# From: Mark Nudelman <markn@greenwoodsoftware.com>
12# To: Elizabeth Flanagan <elizabeth.flanagan@intel.com
13# Date: 12/19/11
14#
15# Hi Elizabeth,
16# Using a generic BSD license for less is fine with me.
17# Thanks,
18#
19# --Mark
20#
21
22LICENSE = "GPLv3+ | BSD-2-Clause"
23LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
24 file://LICENSE;md5=ba01d0cab7f62f7f2204c7780ff6a87d \
25 "
26DEPENDS = "ncurses"
27
28SRC_URI = "http://www.greenwoodsoftware.com/${BPN}/${BPN}-${PV}.tar.gz \
29 "
30
31SRC_URI[md5sum] = "8caff88e34afff512b663d7c690bd2cf"
32SRC_URI[sha256sum] = "6a53639f08d7ed05b6e104b82c32193f79ac01a3eddb20e114e1c261948bd57b"
33
34UPSTREAM_CHECK_URI = "http://www.greenwoodsoftware.com/less/download.html"
35
36inherit autotools update-alternatives
37
38do_install () {
39 oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
40}
41
42ALTERNATIVE_${PN} = "less"
43ALTERNATIVE_PRIORITY = "100"