blob: 611e0cafcc19d427ca0c2596c6546a41b7d08914 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001#
2# Copyright (C) 2019 Konsulko Group
3#
4
5SUMMARY = "Full-featured set of base utils"
6DESCRIPTION = "Package group bringing in packages needed to provide much of the base utils type functionality found in busybox"
7
8inherit packagegroup
9
10VIRTUAL-RUNTIME_vim ?= "vim-tiny"
11
12RDEPENDS_${PN} = "\
13 base-passwd \
14 bash \
15 bind-utils \
16 bzip2 \
17 coreutils \
18 cpio \
19 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "debianutils-run-parts", d)} \
20 dhcp-client \
21 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "dhcp-server", d)} \
22 diffutils \
23 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "dpkg-start-stop", d)} \
24 e2fsprogs \
25 ed \
26 file \
27 findutils \
28 gawk \
29 grep \
30 gzip \
31 ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "", "ifupdown", d)} \
32 inetutils \
33 inetutils-ping \
34 inetutils-telnet \
35 inetutils-tftp \
36 inetutils-traceroute \
37 iproute2 \
38 ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "kbd", "", d)} \
39 kmod \
40 less \
41 ncurses-tools \
42 net-tools \
43 parted \
44 patch \
45 procps \
46 psmisc \
47 sed \
48 shadow-base \
49 tar \
50 time \
51 unzip \
52 util-linux \
53 ${VIRTUAL-RUNTIME_vim} \
54 wget \
55 which \
56 xz \
57 "