blob: 84303e6246f5473881f34eb8bfc1e939a49ed3e3 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
12SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
13 file://xcbincludedir.patch \
14 file://disable-check.patch \
15 file://gcc-mips-pr68302-mips-workaround.patch \
16 "
17
18SRC_URI[md5sum] = "f33cdfc67346f7217a9326c0d8679975"
19SRC_URI[sha256sum] = "a89fb7af7a11f43d2ce84a844a4b38df688c092bf4b67683aef179cdf2a647c4"
20
21BBCLASSEXTEND = "native nativesdk"
22
23DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
24
25PACKAGES_DYNAMIC = "^libxcb-.*"
26
27FILES_${PN} = "${libdir}/libxcb.so.*"
28
29inherit autotools pkgconfig distro_features_check
30
31# The libxau and others requires x11 in DISTRO_FEATURES
32REQUIRED_DISTRO_FEATURES = "x11"
33REQUIRED_DISTRO_FEATURES_class-native = ""
34
35export PYTHON = "python3"
36
37python populate_packages_prepend () {
38 do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
39}