blob: 49c3d62342ce9b1c9cc8a1fd7f8ed87d05707b65 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Pixman: Pixel Manipulation library"
2
3DESCRIPTION = "Pixman provides a library for manipulating pixel regions \
4-- a set of Y-X banded rectangles, image compositing using the \
5Porter/Duff model and implicit mask generation for geometric primitives \
6including trapezoids, triangles, and rectangles."
7
8require xorg-lib-common.inc
9
10# see http://cairographics.org/releases/ - only even minor versions are stable
11UPSTREAM_CHECK_REGEX = "pixman-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)"
12
13LICENSE = "MIT & MIT-style & PD"
14LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \
15 file://pixman/pixman-matrix.c;endline=21;md5=4a018dff3e4e25302724c88ff95c2456 \
16 file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \
17 "
18DEPENDS += "zlib libpng"
19BBCLASSEXTEND = "native nativesdk"
20
21PE = "1"
22
23IWMMXT = "--disable-arm-iwmmxt"
24LOONGSON_MMI = "--disable-loongson-mmi"
25# If target supports neon then disable the 'simd' (ie VFPv2) fallback, otherwise disable neon.
26NEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--disable-arm-simd", "--disable-arm-neon" ,d)}"
27
28EXTRA_OECONF = "--disable-gtk ${IWMMXT} ${LOONGSON_MMI} ${NEON}"
29EXTRA_OECONF_class-native = "--disable-gtk"
30EXTRA_OECONF_class-nativesdk = "--disable-gtk"
31
32SRC_URI += "\
33 file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \
34 file://0001-test-utils-Check-for-FE_INVALID-definition-before-us.patch \
35"
36
37SRC_URI[md5sum] = "04ecad28edcc14e7eb5f7ed6df29c7a0"
38SRC_URI[sha256sum] = "b768e3f7895ddebdc0f07478729d9cec4fe0a9d2201f828c900d67b0e5b436a8"
39
40REQUIRED_DISTRO_FEATURES = ""