blob: 57ac143fd58fc98538a49d84d6080b796238d61f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Small library that defines common error values for all GnuPG components"
2HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://src/gpg-error.h.in;beginline=2;endline=18;md5=cd91e3ad1265a0c268efad541a39345e \
9 file://src/init.c;beginline=2;endline=17;md5=f01cdfcf747af5380590cfd9bbfeaaf7"
10
11
12SECTION = "libs"
13
14UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
15SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
16 file://pkgconfig.patch \
17 "
18
19SRC_URI[md5sum] = "2808a9e044f883f7554c5ba6a380b711"
20SRC_URI[sha256sum] = "cbd5ee62a8a8c88d48c158fff4fc9ead4132aacd1b4a56eb791f9f997d07e067"
21
22BINCONFIG = "${bindir}/gpg-error-config"
23
24inherit autotools binconfig-disabled pkgconfig gettext multilib_header multilib_script
25
26MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/gpgrt-config"
27
28CPPFLAGS += "-P"
29do_compile_prepend() {
30 TARGET_FILE=linux-gnu
31 if [ ${TARGET_OS} = "mingw32" ]; then
32 # There are no arch specific syscfg files for mingw32
33 TARGET_FILE=
34 elif [ ${TARGET_ARCH} = "arc" ]; then
35 # ARC syscfg file is automatically aliased to i686-pc-linux-gnu
36 TARGET_FILE=
37 elif [ ${TARGET_OS} != "linux" ]; then
38 TARGET_FILE=${TARGET_OS}
39 fi
40
41 case ${TARGET_ARCH} in
42 aarch64_be) TUPLE=aarch64-unknown-linux-gnu ;;
43 arm) TUPLE=arm-unknown-linux-gnueabi ;;
44 armeb) TUPLE=arm-unknown-linux-gnueabi ;;
45 i586|i686) TUPLE=i686-unknown-linux-gnu;;
46 mips64*) TUPLE=mips64el-unknown-linux-gnuabi64 ;;
47 mips*el) TUPLE=mipsel-unknown-linux-gnu ;;
48 mips*) TUPLE=mips-unknown-linux-gnu ;;
49 x86_64) TUPLE=x86_64-unknown-linux-gnu ;;
50 ppc) TUPLE=powerpc-unknown-linux-gnu ;;
51 ppc64) TUPLE=powerpc64-unknown-linux-gnu ;;
52 ppc64le) TUPLE=powerpc64le-unknown-linux-gnu ;;
53 *) TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;;
54 esac
55
56 if [ -n "$TARGET_FILE" ]; then
57 cp ${S}/src/syscfg/lock-obj-pub.$TUPLE.h \
58 ${S}/src/syscfg/lock-obj-pub.$TARGET_FILE.h
59 fi
60}
61
62do_install_append() {
63 # we don't have common lisp in OE
64 rm -rf "${D}${datadir}/common-lisp/"
65 oe_multilib_header gpg-error.h gpgrt.h
66}
67
68FILES_${PN}-dev += "${bindir}/gpg-error"
69FILES_${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
70
71BBCLASSEXTEND = "native nativesdk"