blob: b4b6e2323dcef4475106ac9324ff2846e1f73981 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Userspace RCU (read-copy-update) library"
2HOMEPAGE = "http://lttng.org/urcu"
3BUGTRACKER = "http://lttng.org/project/issues"
4
5LICENSE = "LGPLv2.1+ & MIT-style"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e548d28737289d75a8f1e01ba2fd7825 \
7 file://src/urcu.h;beginline=4;endline=32;md5=4de0d68d3a997643715036d2209ae1d9 \
8 file://include/urcu/uatomic/x86.h;beginline=4;endline=21;md5=58e50bbd8a2f073bb5500e6554af0d0b"
9
10SRC_URI = "http://lttng.org/files/urcu/userspace-rcu-${PV}.tar.bz2 \
11 file://Add-support-for-the-RISC-V-architecture.patch \
12 "
13
14SRC_URI[md5sum] = "7c424c5183ec009d87e0f70c23e92f1b"
15SRC_URI[sha256sum] = "b3f6888daf6fe02c1f8097f4a0898e41b5fe9975e121dc792b9ddef4b17261cc"
16
17S = "${WORKDIR}/userspace-rcu-${PV}"
18inherit autotools multilib_header
19
20CPPFLAGS_append_riscv64 = " -pthread -D_REENTRANT"
21
22do_install_append() {
23 oe_multilib_header urcu/config.h
24}