blob: 28d404ca77925f533f4081f6b28a052254f7a330 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "GNOME XSLT library"
2HOMEPAGE = "http://xmlsoft.org/XSLT/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://Copyright;md5=0cd9a07afbeb24026c9b03aecfeba458"
7
8SECTION = "libs"
9DEPENDS = "libxml2"
10
11SRC_URI = "http://xmlsoft.org/sources/libxslt-${PV}.tar.gz"
12
13SRC_URI[md5sum] = "b3bd254a03e46d58f8ad1e4559cd2c2f"
14SRC_URI[sha256sum] = "8e36605144409df979cab43d835002f63988f3dc94d5d3537c12796db90e38c8"
15
16UPSTREAM_CHECK_REGEX = "libxslt-(?P<pver>\d+(\.\d+)+)\.tar"
17
18S = "${WORKDIR}/libxslt-${PV}"
19
20BINCONFIG = "${bindir}/xslt-config"
21
22inherit autotools pkgconfig binconfig-disabled lib_package
23
24# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
25do_configure_prepend () {
26 sed -i -e 's/ansidecl.h//' ${S}/configure.ac
27
28 # The timestamps in the 1.1.28 tarball are messed up causing this file to
29 # appear out of date. Touch it so that we don't try to regenerate it.
30 touch ${S}/doc/xsltproc.1
31}
32
33EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto --with-html-subdir=${BPN}"
34# older versions of this recipe had ${PN}-utils
35RPROVIDES_${PN}-bin += "${PN}-utils"
36RCONFLICTS_${PN}-bin += "${PN}-utils"
37RREPLACES_${PN}-bin += "${PN}-utils"
38
39# This is only needed until libxml can load the relocated catalog itself
40do_install_append_class-native () {
41 create_wrapper ${D}/${bindir}/xsltproc XML_CATALOG_FILES=${sysconfdir}/xml/catalog
42}
43
44FILES_${PN} += "${libdir}/libxslt-plugins"
45FILES_${PN}-dev += "${libdir}/xsltConf.sh"
46
47BBCLASSEXTEND = "native nativesdk"