blob: 8dcd48973a74cfeabe3ab23c0e86f948eb11a485 [file] [log] [blame]
Brad Bishop7fe43db2016-04-15 09:53:23 -04001SUMMARY = "Inventory upload"
2DESCRIPTION = "Inventory upload."
3HOMEPAGE = "http://github.com/openbmc/openpower-inventory-upload"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
7
8inherit allarch
9inherit setuptools
Brad Bishop1d525fa2016-08-17 20:27:37 -040010inherit obmc-phosphor-systemd
Brad Bishop7fe43db2016-04-15 09:53:23 -040011
12RDEPENDS_${PN} += " \
Brad Bishopf441ae32016-05-03 10:51:48 -040013 python-dbus \
14 python-pygobject \
Brad Bishop7fe43db2016-04-15 09:53:23 -040015 pyphosphor \
16 dtc \
17 "
18
19SRC_URI += "git://github.com/openbmc/openpower-inventory-upload"
20
Andrew Geissler910303a2018-05-21 21:15:03 -050021SRCREV = "c115852fb5aa0890373d8c2dfca9b9f7b1e06527"
Brad Bishop7fe43db2016-04-15 09:53:23 -040022
23S = "${WORKDIR}/git"
Brad Bishop1d525fa2016-08-17 20:27:37 -040024
25TMPL = "op-inventory-upload@.service"
26INSTFMT = "op-inventory-upload@{0}.service"
Josh D. Kingefb04a12017-04-06 15:56:37 -050027TGTFMT = "obmc-host-start@{0}.target"
Brad Bishop1d525fa2016-08-17 20:27:37 -040028FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
29
30SYSTEMD_SERVICE_${PN} += "${TMPL}"
31SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"