blob: 97ea50d8005ceea8f81048c9f43ec13a9fc4c973 [file] [log] [blame]
Naveen Mosesc8d90aa2021-10-07 18:20:33 +05301FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3SRC_URI:append:fb-withhost += "file://set-bmc-time-from-host"
4
5
6RDEPENDS:${PN}:append:fb-withhost += "bash"
7
8do_install:append:fb-withhost(){
9
10 # Store the bitbake variable OBMC_HOST_INSTANCES inside time sync script as HOST_INSTANCES variable using sed.
11 sed -i -e "s,HOST_INSTANCES_SED_REPLACEMENT_VALUE,${OBMC_HOST_INSTANCES},g" ${WORKDIR}/set-bmc-time-from-host
12
13 install -d ${D}$/lib/systemd/system
14 install -m 0644 ${WORKDIR}/bmc-set-time.service ${D}$/lib/systemd/system
15 install -d ${D}/usr/libexec
16 install -m 0777 ${WORKDIR}/set-bmc-time-from-host ${D}/usr/libexec
17}
18
19SYSTEMD_SERVICE:${PN}:fb-withhost += "bmc-set-time.service"