blob: 16add36d8d3b3f2e7adfb8d4f6cb6499bb6a968d [file] [log] [blame]
William A. Kennington III1987be72019-05-16 01:05:58 -07001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2SRC_URI += "file://10-nice.conf"
3
4inherit systemd
5
6FILES_${PN} += "${systemd_unitdir}/system/rngd.service.d"
7
8do_install_append() {
9 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
10 install -d ${D}${systemd_unitdir}/system/rngd.service.d
11 install -m 644 ${WORKDIR}/10-nice.conf ${D}${systemd_unitdir}/system/rngd.service.d
12 fi
13}