blob: 024626cbfa6c748e56d101c0aae124b9023001cd [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001
2# enable the overrides for the context of the conf only
3OVERRIDES .= ":qemuboot-xilinx"
4
5# setup the target binary
6QB_SYSTEM_NAME_prepend = "qemu-xilinx/"
7
8# Default machine targets for Xilinx QEMU (FDT Generic)
9QB_MACHINE_aarch64 = "-machine arm-generic-fdt"
10QB_MACHINE_arm = "-machine arm-generic-fdt-7series"
11QB_MACHINE_microblaze = "-machine microblaze-generic-fdt-plnx"
12
13# defaults
14QB_DEFAULT_KERNEL ?= "none"
15
16inherit qemuboot
17
18# rewrite the qemuboot with the custom sysroot bindir
19python do_write_qemuboot_conf_append() {
20 val = os.path.join(d.getVar('BASE_WORKDIR'), d.getVar('BUILD_SYS'), 'qemu-xilinx-helper-native/1.0-r1/recipe-sysroot-native/usr/bin/')
21 cf.set('config_bsp', 'STAGING_BINDIR_NATIVE', '%s' % val)
22
23 # write out the updated version from this append
24 with open(qemuboot, 'w') as f:
25 cf.write(f)
26}
27