Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Xilinx BSP device trees" |
| 2 | DESCRIPTION = "Xilinx BSP device trees from within layer." |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 3 | SECTION = "bsp" |
| 4 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 5 | # the device trees from within the layer are licensed as MIT, kernel includes are GPL |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 6 | LICENSE = "MIT & GPLv2" |
| 7 | LIC_FILES_CHKSUM = " \ |
| 8 | file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \ |
| 9 | file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \ |
| 10 | " |
| 11 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | inherit devicetree |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 13 | |
| 14 | PROVIDES = "virtual/dtb" |
| 15 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | # common zynq include |
| 17 | SRC_URI_append_zynq = " file://zynq-7000-qspi-dummy.dtsi" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 18 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | # device tree sources for the various machines |
| 20 | COMPATIBLE_MACHINE_picozed-zynq7 = ".*" |
| 21 | SRC_URI_append_picozed-zynq7 = " file://picozed-zynq7.dts" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 22 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | COMPATIBLE_MACHINE_qemu-zynq7 = ".*" |
| 24 | SRC_URI_append_qemu-zynq7 = " file://qemu-zynq7.dts" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 25 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | COMPATIBLE_MACHINE_zybo-linux-bd-zynq7 = ".*" |
| 27 | SRC_URI_append_zybo-linux-bd-zynq7 = " \ |
| 28 | file://zybo-linux-bd-zynq7.dts \ |
| 29 | file://pcw.dtsi \ |
| 30 | file://pl.dtsi \ |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 31 | " |
| 32 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | COMPATIBLE_MACHINE_kc705-microblazeel = ".*" |
| 34 | SRC_URI_append_kc705-microblazeel = " \ |
| 35 | file://kc705-microblazeel.dts \ |
| 36 | file://pl.dtsi \ |
| 37 | file://system-conf.dtsi \ |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 38 | " |
| 39 | |