blob: 1a15e53b8fe281710ac63d35d38be2ea1725b011 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4DEPENDS = "libusb-compat libftdi"
5RDEPENDS_${PN} = "libusb1"
6
Brad Bishop757e94a2018-09-07 18:58:51 +00007SRC_URI = " \
8 git://repo.or.cz/openocd.git;protocol=http;name=openocd \
9 git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \
10 git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \
11 git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \
12 file://0001-Add-fallthrough-comments.patch \
13 file://0002-Workaround-new-warnings-generated-by-GCC-7.patch \
14 file://0003-armv7a-Add-missing-break-to-fix-fallthrough-warning.patch \
15 file://0004-Fix-overflow-warning.patch \
16 file://0005-command-Move-the-fall-through-comment-to-right-scope.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017"
Brad Bishop757e94a2018-09-07 18:58:51 +000018SRCREV_FORMAT = "openocd"
19SRCREV_openocd = "1025be363e2bf42f1613083223a2322cc3a9bd4c"
20SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba"
21SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787"
22SRCREV_libjaylink = "699b7001d34a79c8e7064503dde1bede786fd7f0"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023
24PV = "0.10+gitr${SRCPV}"
25S = "${WORKDIR}/git"
26
27inherit pkgconfig autotools-brokensep gettext
28
29BBCLASSEXTEND += "nativesdk"
30
Brad Bishop757e94a2018-09-07 18:58:51 +000031EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032
33do_configure() {
Brad Bishop757e94a2018-09-07 18:58:51 +000034 ./bootstrap nosubmodule
Brad Bishopd7bf8c12018-02-25 22:55:05 -050035 oe_runconf ${EXTRA_OECONF}
36}
37
38do_install() {
39 oe_runmake DESTDIR=${D} install
40 if [ -e "${D}${infodir}" ]; then
41 rm -Rf ${D}${infodir}
42 fi
43 if [ -e "${D}${mandir}" ]; then
44 rm -Rf ${D}${mandir}
45 fi
46 if [ -e "${D}${bindir}/.debug" ]; then
47 rm -Rf ${D}${bindir}/.debug
48 fi
49}
50
51FILES_${PN} = " \
52 ${datadir}/openocd/* \
53 ${bindir}/openocd \
54 "
55
56PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
57PACKAGECONFIG ??= "sysfsgpio"