blob: 20bc663f98257d8384d7d840a22dcb87486393c7 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Free and Open On-Chip Debugging, In-System Programming and Boundary-Scan Testing"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4DEPENDS = "libusb-compat libftdi"
5RDEPENDS_${PN} = "libusb1"
6
7SRC_URI = "git://repo.or.cz/openocd.git \
8 file://0001-Add-fallthrough-comments.patch \
9 file://0002-Workaround-new-warnings-generated-by-GCC-7.patch \
10 file://0003-armv7a-Add-missing-break-to-fix-fallthrough-warning.patch \
11 file://0004-Fix-overflow-warning.patch \
12 file://0005-command-Move-the-fall-through-comment-to-right-scope.patch \
13"
14SRCREV = "1025be363e2bf42f1613083223a2322cc3a9bd4c"
15
16PV = "0.10+gitr${SRCPV}"
17S = "${WORKDIR}/git"
18
19inherit pkgconfig autotools-brokensep gettext
20
21BBCLASSEXTEND += "nativesdk"
22
23EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html "
24
25do_configure() {
26 ./bootstrap
27 oe_runconf ${EXTRA_OECONF}
28}
29
30do_install() {
31 oe_runmake DESTDIR=${D} install
32 if [ -e "${D}${infodir}" ]; then
33 rm -Rf ${D}${infodir}
34 fi
35 if [ -e "${D}${mandir}" ]; then
36 rm -Rf ${D}${mandir}
37 fi
38 if [ -e "${D}${bindir}/.debug" ]; then
39 rm -Rf ${D}${bindir}/.debug
40 fi
41}
42
43FILES_${PN} = " \
44 ${datadir}/openocd/* \
45 ${bindir}/openocd \
46 "
47
48PACKAGECONFIG[sysfsgpio] = "--enable-sysfsgpio,--disable-sysfsgpio"
49PACKAGECONFIG ??= "sysfsgpio"