blob: 1a4261a9eadb927d00b93a66b83a03ccf3c1c14f [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Administration program for the grsecurity RBAC syste"
2DESCRIPTION = "\
3gradm is the userspace RBAC parsing and authentication program for \
4grsecurity grsecurity aims to be a complete security system. gradm \
5performs several tasks for the RBAC system including authenticated \
6via a password to the kernel and parsing rules to be passed to the \
7kernel"
8HOMEPAGE = "http://grsecurity.net/index.php"
9SECTION = "admin"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
12DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
14SRC_URI = "http://grsecurity.net/stable/${BP}-201507191652.tar.gz \
Brad Bishop7f28bc52017-12-03 23:42:40 -050015 file://0001-Makefile-remove-strip.patch \
16 file://0001-Makefile-Append-instead-of-overriding-LDFLAGS.patch \
17 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018SRC_URI[md5sum] = "ecec72d3a9b6d84c00eda97957b707b6"
19SRC_URI[sha256sum] = "2f14c357bf0459e502a4e108b76c3f6240aa484762d07bb1687796b9b9297a50"
20
21S = "${WORKDIR}/gradm"
22
23inherit autotools-brokensep
24
25do_compile() {
26 oe_runmake 'CC=${CC}' \
27 'OPT_FLAGS=${CFLAGS}' \
28 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
29 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
30 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
31 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)}
32}
33
34do_install() {
35 oe_runmake 'CC=${CC}' \
36 'DESTDIR=${D}' \
37 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
38 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
39 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
40 install
41
42 # The device nodes are generated by postinstall or udev
43 rm -rf ${D}/dev
44}
45
46pkg_postinst_${PN}() {
47 # make sure running on the target
48 if [ x"$D" != "x" ]; then
49 exit 1
50 fi
51 /bin/mknod -m 0622 /dev/grsec c 1 13
52}