blob: 252b19de2d120accbfad96739e71808974f1fb5c [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Administration program for the grsecurity RBAC syste"
2DESCRIPTION = "\
3gradm is the userspace RBAC parsing and authentication program for \
4grsecurity grsecurity aims to be a complete security system. gradm \
5performs several tasks for the RBAC system including authenticated \
6via a password to the kernel and parsing rules to be passed to the \
7kernel"
8HOMEPAGE = "http://grsecurity.net/index.php"
9SECTION = "admin"
10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
12DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
14SRC_URI = "http://grsecurity.net/stable/${BP}-201507191652.tar.gz \
15 file://0001-Makefile-remove-strip.patch"
16SRC_URI[md5sum] = "ecec72d3a9b6d84c00eda97957b707b6"
17SRC_URI[sha256sum] = "2f14c357bf0459e502a4e108b76c3f6240aa484762d07bb1687796b9b9297a50"
18
19S = "${WORKDIR}/gradm"
20
21inherit autotools-brokensep
22
23do_compile() {
24 oe_runmake 'CC=${CC}' \
25 'OPT_FLAGS=${CFLAGS}' \
26 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
27 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
28 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)}
30}
31
32do_install() {
33 oe_runmake 'CC=${CC}' \
34 'DESTDIR=${D}' \
35 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
36 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
37 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
38 install
39
40 # The device nodes are generated by postinstall or udev
41 rm -rf ${D}/dev
42}
43
44pkg_postinst_${PN}() {
45 # make sure running on the target
46 if [ x"$D" != "x" ]; then
47 exit 1
48 fi
49 /bin/mknod -m 0622 /dev/grsec c 1 13
50}