blob: ee5ffd5da8c889d354287612c157b1be6d0798d6 [file] [log] [blame]
causten13cd0ca2017-09-26 11:08:47 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3inherit systemd
4inherit obmc-phosphor-systemd
5
6SRC_URI += " \
7 file://nginx.conf \
8 file://nginx.service \
9 file://gen-cert.sh \
10 "
11
Brad Bishop6b37f332018-12-11 10:47:34 -050012RDEPENDS_${PN} += " \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013 openssl-bin \
Brad Bishop6b37f332018-12-11 10:47:34 -050014 ${VIRTUAL-RUNTIME_base-utils} \
15 "
16
Deepak Kodihallief18a482018-07-30 03:41:43 -050017EXTRA_OECONF =+ " --without-select_module --with-http_gunzip_module"
causten13cd0ca2017-09-26 11:08:47 -050018
19SSLCERTPATH = "/etc/ssl/certs/nginx/"
20
21
22do_install_append() {
23
24 install -m 644 ${WORKDIR}/nginx.conf ${D}${sysconfdir}/nginx
25 install -m 0755 ${WORKDIR}/gen-cert.sh ${D}${sbindir}/gen-cert.sh
26
27 install -d ${D}${SSLCERTPATH}
28 chown -R www:www-data ${D}${SSLCERTPATH}
29
30
31 echo SSLCERTPATH
32 echo ${SSLCERTPATH}
33 sed -i 's,@CERTPATH@,${SSLCERTPATH},g' ${D}${sysconfdir}/nginx/nginx.conf
34}
35
36FILES_${PN} += " ${SSLCERTPATH} "
37
38SYSTEMD_SERVICE_${PN} += " nginx.service"