blob: 50865cccda26462164d8efef9366f744c157ba31 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "1-Wire file system"
2DESCRIPTION = "OWFS is an easy way to use the powerful 1-wire system of Dallas/Maxim"
3HOMEPAGE = "http://www.owfs.org/"
4SECTION = "console/network"
5
6LICENSE = "GPLv2 & LGPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12a64df1cc87275e940cab05ee75c37d \
8 file://COPYING.LIB;md5=16ff3ffebed582e19ea7a4f48ec77b42"
9
10DEPENDS = "fuse virtual/libusb0"
11# v3.2p2
12SRCREV = "93c1f36d9ac481075287da331d5184f590f8c0fa"
13SRC_URI = "git://github.com/owfs/owfs \
14 file://owhttpd \
15 file://owserver \
16 file://0001-include-sys-sysmacros.h-for-major.patch \
17 "
18
19S = "${WORKDIR}/git"
20
21inherit autotools-brokensep update-rc.d pkgconfig
22
23EXTRA_OECONF = " \
24 --with-fuseinclude=${STAGING_INCDIR} \
25 --with-fuselib=${STAGING_LIBDIR} \
26 --enable-owfs \
27 --enable-owhttpd \
28 --enable-w1 \
29 --disable-swig \
30 --disable-owtcl \
31 --disable-owphp \
32 --disable-owpython \
33 --disable-owperl \
34"
35
36do_install_prepend() {
37 install -d ${D}${sysconfdir}/default/
38 install -d ${D}${sysconfdir}/init.d/
39 install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
40 install -m 0755 ${WORKDIR}/owserver ${D}${sysconfdir}/init.d/owserver
41}
42
43PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
44
45DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access"
46DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control"
47DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control"
48DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
49DESCRIPTION_libowcapi = "easy C-language 1-wire interface "
50DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol"
51DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol"
52DESCRIPTION_owmon = "Monitor for owserver settings and statistics"
53DESCRIPTION_owtap = "Packet sniffer for the owserver protocol"
54
55FILES_owftpd = "${bindir}/owftpd"
56FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd"
57FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver"
58FILES_owshell = "${bindir}/owread ${bindir}/owwrite \
59 ${bindir}/owdir ${bindir}/owpresent \
60 ${bindir}/owget ${bindir}/owside"
61FILES_owmon = "${bindir}/owmon"
62FILES_owtap = "${bindir}/owtap"
63FILES_libowcapi = "${libdir}/libowcapi-*"
64FILES_libow = "${libdir}/libow-*"
65FILES_libownet = "${libdir}/libownet-*"
66
67INITSCRIPT_PACKAGES = "owhttpd owserver"
68INITSCRIPT_NAME_owserver = "owserver"
69INITSCRIPT_NAME_owhttpd = "owhttpd"
70INITSCRIPT_PARAMS_owserver = "defaults 20"
71INITSCRIPT_PARAMS_owhttpd = "defaults 21"