blob: caa75c7f53ecd1fefa891fc1cf9945bdffcfa418 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3 programs to export a virtual filesystem to the Linux kernel. FUSE \
4 also aims to provide a secure method for non privileged users to \
5 create and mount their own filesystem implementations. \
6 "
7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs"
9LICENSE = "GPLv2 & LGPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
12
13SRC_URI = "https://github.com/libfuse/libfuse/releases/download/${BP}/${BP}.tar.gz \
14 file://gold-unversioned-symbol.patch \
15 file://aarch64.patch \
16 file://0001-fuse-fix-the-return-value-of-help-option.patch \
17 file://fuse.conf \
18"
19SRC_URI[md5sum] = "f365e848a82504edb0b7a33df790ca78"
20SRC_URI[sha256sum] = "5e84f81d8dd527ea74f39b6bc001c874c02bad6871d7a9b0c14efb57430eafe3"
21
22UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
23UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>2(\.\d+)+).tar.gz"
24
25inherit autotools pkgconfig update-rc.d systemd
26
27INITSCRIPT_NAME = "fuse"
28INITSCRIPT_PARAMS = "start 3 S . stop 20 0 6 ."
29
30SYSTEMD_SERVICE_${PN} = ""
31
32DEPENDS = "gettext-native"
33
34PACKAGES =+ "fuse-utils libulockmgr libulockmgr-dev"
35
36RPROVIDES_${PN}-dbg += "fuse-utils-dbg libulockmgr-dbg"
37
38RRECOMMENDS_${PN}_class-target = "kernel-module-fuse libulockmgr fuse-utils"
39
40FILES_${PN} += "${libdir}/libfuse.so.*"
41FILES_${PN}-dev += "${libdir}/libfuse*.la"
42
43FILES_libulockmgr = "${libdir}/libulockmgr.so.*"
44FILES_libulockmgr-dev += "${libdir}/libulock*.la"
45
46# Forbid auto-renaming to libfuse-utils
47FILES_fuse-utils = "${bindir} ${base_sbindir}"
48DEBIAN_NOAUTONAME_fuse-utils = "1"
49DEBIAN_NOAUTONAME_${PN}-dbg = "1"
50
51do_configure_prepend() {
52 # Make this explicit so overriding base_sbindir propagates properly.
53 export MOUNT_FUSE_PATH="${base_sbindir}"
54}
55
56do_install_append() {
57 rm -rf ${D}${base_prefix}/dev
58
59 # systemd class remove the sysv_initddir only if systemd_system_unitdir
60 # contains anything, but it's not needed if sysvinit is not in DISTRO_FEATURES
61 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'false', 'true', d)}; then
62 rm -rf ${D}${sysconfdir}/init.d/
63 fi
64
65 # Install systemd related configuration file
66 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
67 install -d ${D}${sysconfdir}/modules-load.d
68 install -m 0644 ${WORKDIR}/fuse.conf ${D}${sysconfdir}/modules-load.d
69 fi
70}
71
72BBCLASSEXTEND = "native nativesdk"