blob: 54ab30cbbb0bfcc8ad5cad3f8b5aeabea5734ea8 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "XFS Filesystem Dump Utility"
2DESCRIPTION = "The xfsdump package contains xfsdump, xfsrestore and a \
3 number of other utilities for administering XFS filesystems.\
4 xfsdump examines files in a filesystem, determines which \
5 need to be backed up, and copies those files to a \
6 specified disk, tape or other storage medium."
7HOMEPAGE = "http://oss.sgi.com/projects/xfs"
8SECTION = "base"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://doc/COPYING;md5=15c832894d10ddd00dfcf57bee490ecc"
11DEPENDS = "xfsprogs attr"
12
13SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsdump/${BP}.tar.xz \
14 file://remove-install-as-user.patch \
15 "
16SRC_URI[md5sum] = "84d3bc287b4a2bb5d16b2320a47049a7"
17SRC_URI[sha256sum] = "ed14e67ae5b273c2698e767b43a46f033d361e540fe13feaaf9b110ee0edc585"
18
19inherit autotools-brokensep
20
21PARALLEL_MAKE = ""
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[gettext] = "--enable-gettext=yes,--enable-gettext=no,gettext"
24
25CFLAGS += "-D_FILE_OFFSET_BITS=64"
26
27EXTRA_OEMAKE += "'LIBTOOL=${HOST_SYS}-libtool' V=1"
28
29do_configure () {
30 export DEBUG="-DNDEBUG"
31 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
32 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
33 oe_runconf
34}
35
36do_install () {
37 export DIST_ROOT=${D}
38 oe_runmake install
39 oe_runmake install-dev
40}