blob: 0a1bacb9354a7ae70217b59648f7102d2f4d7753 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "XFS Filesystem Utilities"
2HOMEPAGE = "http://oss.sgi.com/projects/xfs"
3SECTION = "base"
4LICENSE = "GPLv2 & LGPLv2.1"
5LICENSE_libhandle = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038 \
7 file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
8DEPENDS = "util-linux util-linux-native"
9SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \
10 file://remove_flags_from_build_flags.patch \
11 file://0001-build-Check-for-sync_file_range-libc-function.patch \
12 file://disable-xfs_scrub-build.patch \
13 file://0001-Check-for-MAP_SYNC-in-sys-mman.h.patch \
14 file://0002-include-include-xfs-linux.h-after-sys-mman.h.patch \
15 "
16SRC_URI[md5sum] = "5f80b631b68df89a8b9283307e96d2e8"
17SRC_URI[sha256sum] = "397dc96f51aeeff73d021d3418d3172377b2685f2740ca60525096c070aa3df1"
18
19inherit autotools-brokensep
20
21PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle"
22
23DEPENDS += "util-linux"
24
25RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs ${PN}-repair"
26
27FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs"
28FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs"
29FILES_${PN}-repair = "${base_sbindir}/xfs_repair"
30
31FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
32
33EXTRA_OECONF = "--enable-gettext=no \
34 INSTALL_USER=root \
35 INSTALL_GROUP=root \
36 ac_cv_header_aio_h=yes \
37 ac_cv_lib_rt_lio_listio=yes \
38"
39
40DISABLE_STATIC = ""
41EXTRA_AUTORECONF += "-I ${S}/m4 --exclude=autoheader"
42
43PACKAGECONFIG ??= "readline blkid"
44
45PACKAGECONFIG[readline] = "--enable-readline=yes,--enable-readline=no,readline"
46PACKAGECONFIG[blkid] = "--enable-blkid=yes,--enable-blkid=no,util-linux"
47
48export DEBUG="-DNDEBUG"
49export BUILD_VERBOSE="1"
50export tagname="CC"
51
52EXTRA_OEMAKE = "DIST_ROOT='${D}'"
53
54do_configure () {
55 export BUILD_CC="${BUILD_CC} ${BUILD_CFLAGS}"
56 # Prevent Makefile from calling configure without arguments,
57 # when do_configure gets called for a second time.
58 rm -f ${B}/include/builddefs ${B}/include/platform_defs.h ${B}/configure
59 # Recreate configure script.
60 oe_runmake configure
61 oe_runconf
62}
63
64do_install_append() {
65 oe_runmake 'DESTDIR=${D}' install-dev
66 rm ${D}${libdir}/*.la
67 rmdir --ignore-fail-on-non-empty ${D}${libdir}
68}