blob: ba69e2e0cd2ca6e9e628baec6de42ee546d20977 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Compatibility library for accessing secrets"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2 & LGPLv2"
6LIC_FILES_CHKSUM = " \
7 file://COPYING;md5=0914b9d3ebaba41ef2e3e0ae16f296cf \
8 file://COPYING.GPL;md5=94d55d512a9ba36caa9b7df079bae19f \
9"
10SECTION = "x11/gnome/libs"
11
12inherit gnomebase gtk-doc gobject-introspection
13
14DEPENDS = "dbus libgcrypt glib-2.0 glib-2.0-native intltool-native"
15
16SRC_URI[archive.md5sum] = "6696e4f2e9aed4625cdc3af30bd8c238"
17SRC_URI[archive.sha256sum] = "c4c178fbb05f72acc484d22ddb0568f7532c409b0a13e06513ff54b91e947783"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19
20# Fails to build with thumb-1 (qemuarm)
21#| {standard input}: Assembler messages:
22#| {standard input}:823: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#3'
23#| {standard input}:823: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#13'
24#| {standard input}:824: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#29'
25#| {standard input}:824: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r12,r12,ror#19'
26#| {standard input}:825: Error: lo register required -- `orr r10,r10,r10'
27ARM_INSTRUCTION_SET_armv5 = "arm"
28ARM_INSTRUCTION_SET_armv4 = "arm"
29