blob: 82ccf3eda73937442af25d023769a5ecd50c6187 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "The usermode contains the userhelper program, which can be used to allow configured \
2programs to be run with superuser privileges by ordinary users, and several \
3graphical tools for users: \
4* userinfo allows users to change their finger information. \
5* usermount lets users mount, unmount, and format filesystems. \
6* userpasswd allows users to change their passwords. \
7"
8HOMEPAGE = "https://pagure.io/usermode"
9LICENSE = "GPLv2+"
10DEPENDS = "libuser ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} \
11 gtk+ desktop-file-utils-native \
12 startup-notification intltool-native \
13 util-linux \
14"
15
16SRC_URI = "https://releases.pagure.org/${BPN}/${BPN}-${PV}.tar.xz \
17 file://0001-fix-compile-failure-against-musl-C-library.patch \
18 file://0001-Makefile.am-Link-with-libm-for-powl-API.patch \
19 file://0001-Missing-n-in-translated-string.patch \
20 file://0001-Include-sys-sysmacros.h-for-major-minor.patch \
21 "
22SRC_URI[md5sum] = "a766a9f7600f573fb6de4655d4162196"
23SRC_URI[sha256sum] = "37c4d667209da14082c08df6e48fe955d1532efebd5322f13f94683c6cc10370"
24
25LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
26
27inherit distro_features_check autotools gettext pkgconfig
28
29EXTRA_OEMAKE += "INSTALL='install -p'"
30
31REQUIRED_DISTRO_FEATURES = "x11 pam"