blob: 6d79e8f83feced92ce88bfcdf170f6260007437a [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "kexecboot linux-as-bootloader"
2DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec."
3HOMEPAGE = "http://kexecboot.org"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6PV = "0.6+git${SRCPV}"
7S = "${WORKDIR}/git"
8SRC_URI = "git://github.com/kexecboot/kexecboot.git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRCREV = "4c01d6960aa6a9d03675605062469ab777fa2b01"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010inherit autotools
11
12EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250"
13
14do_install () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015 install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016 install -d ${D}/proc
17 install -d ${D}/mnt
18 install -d ${D}/dev
19 install -d ${D}/sys
20}
21
22PACKAGE_ARCH = "${MACHINE_ARCH}"
23
24FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
25
26pkg_postinst_${PN} () {
27 ln -sf ${bindir}/kexecboot $D/init
28}
29
30BBCLASSEXTEND = "klibc"