blob: 21331ffcb00a4c35327dc8c1da81be6f39ff6d18 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A UPnP AV media server and renderer"
2DESCRIPTION = "Rygel is a home media solution (UPnP AV MediaServer) that \
3allow you to easily share audio, video and pictures to other devices. \
4Additionally, media player software may use Rygel to become a MediaRenderer \
5that may be controlled remotely by a UPnP or DLNA Controller."
6HOMEPAGE = "http://live.gnome.org/Rygel"
7
Brad Bishop2eeb5252018-09-10 18:40:16 +00008LICENSE = "LGPL-2.1"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
10
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 gstreamer1.0-plugins-base libgee libsoup-2.4 libmediaart-2.0 libunistring sqlite3 intltool-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info"
13RRECOMMENDS_${PN} = "rygel-plugin-media-export"
14
15GNOME_COMPRESS_TYPE = "xz"
16SRC_URI[archive.md5sum] = "7d8923324b280cd5452803d61176a34a"
17SRC_URI[archive.sha256sum] = "fbb2d46cbe4e750df6610b4c66b2278f06d1f71a257c7903e676ccb394dad418"
18
19inherit gnomebase vala gobject-introspection gettext systemd
20
21EXTRA_OECONF = "--disable-tracker-plugin --with-media-engine=gstreamer"
22
23PACKAGECONFIG ?= "external mpris ruih media-export gst-launch"
24
25PACKAGECONFIG_append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}"
26
27PACKAGECONFIG[external] = "--enable-external-plugin,--disable-external-plugin"
28PACKAGECONFIG[mpris] = "--enable-mpris-plugin,--disable-mpris-plugin"
29PACKAGECONFIG[ruih] = "--enable-ruih-plugin,--disable-ruih-plugin"
30PACKAGECONFIG[media-export] = "--enable-media-export-plugin,--disable-media-export-plugin"
31PACKAGECONFIG[gst-launch] = "--enable-gst-launch-plugin,--disable-gst-launch-plugin"
32PACKAGECONFIG[gtk+3] = ",--without-ui,gtk+3"
Brad Bishop316dfdd2018-06-25 12:45:53 -040033PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034
35LIBV = "2.6"
36
37do_install_append() {
38 # Remove .la files for loadable modules
39 rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la
40 rm -f ${D}/${libdir}/rygel-${LIBV}/plugins/*.la
41 if [ -e ${D}${libdir}/systemd/user/rygel.service ]; then
42 mkdir -p ${D}${systemd_unitdir}/system
43 mv ${D}${libdir}/systemd/user/rygel.service ${D}${systemd_unitdir}/system
44 rmdir ${D}${libdir}/systemd/user ${D}${libdir}/systemd
45 fi
46}
47
48FILES_${PN} += "${libdir}/rygel-${LIBV}/engines ${datadir}/dbus-1 ${datadir}/icons"
49FILES_${PN}-dbg += "${libdir}/rygel-${LIBV}/engines/.debug ${libdir}/rygel-${LIBV}/plugins/.debug"
50
51PACKAGES += "${PN}-meta"
52ALLOW_EMPTY_${PN}-meta = "1"
53
54PACKAGES_DYNAMIC = "${PN}-plugin-*"
55
56SYSTEMD_SERVICE_${PN} = "rygel.service"
57
58python populate_packages_prepend () {
59 rygel_libdir = d.expand('${libdir}/rygel-${LIBV}')
60 postinst = d.getVar('plugin_postinst')
61 pkgs = []
62
63 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), 'librygel-(.*)\.so$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
64 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), '(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
65
66 metapkg = d.getVar('PN') + '-meta'
67 d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
68}