blob: ca9d94a19cb2a3adb363c3d1a58a9332ee4bf5c8 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "MusicBrainz client library"
2DESCRIPTION = "The MusicBrainz client is a library which can be built into other programs. The library allows you to access the data held on the MusicBrainz server."
3HOMEPAGE = "http://musicbrainz.org"
4LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING.txt;md5=fbc093901857fcd118f065f900982c24"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006DEPENDS = "expat libxml2 libxml2-native neon neon-native"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007
Brad Bishop6e60e8b2018-02-01 10:27:11 -05008PV = "5.1.0+git${SRCPV}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010SRCREV = "44c05779dd996035758f5ec426766aeedce29cc3"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011SRC_URI = "git://github.com/metabrainz/libmusicbrainz.git \
12 file://allow-libdir-override.patch "
13
14S = "${WORKDIR}/git"
15
Patrick Williamsb48b7b42016-08-17 15:04:38 -050016inherit cmake pkgconfig
17
18do_configure_prepend() {
19 # The native build really doesn't like being rebuilt, so delete
20 # it if it's already present. Also delete all other files not
21 # known to Git to fix subsequent invocations of do_configure.
22 git clean -dfx -e /.pc/ -e /patches/ .
23 mkdir build-native
24 cd build-native
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025 LDFLAGS="${BUILD_LDFLAGS}" \
26 cmake -DCMAKE_C_FLAGS=${BUILD_CFLAGS} \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050027 -DCMAKE_C_COMPILER=${BUILD_CC} \
28 -DCMAKE_CXX_FLAGS=${BUILD_CXXFLAGS} \
29 -DCMAKE_CXX_COMPILER=${BUILD_CXX} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030 -DCMAKE_EXE_LINKER_FLAGS=${BUILD_LDFLAGS} \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050031 ..
32 make make-c-interface
33 cd ..
34}
35
36EXTRA_OECMAKE = "-DLIB_INSTALL_DIR:PATH=${libdir} \
37 -DIMPORT_EXECUTABLES=build-native/ImportExecutables.cmake"
38
39# out-of-tree building doesn't appear to work for this package.
40B = "${S}"