blob: 455e76fcb3a24a3ecb4f54c14c4a9d02e168ad03 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "C client library for the Music Player Daemon"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=06b9dfd2f197dc514d8ef06549684b77"
4HOMEPAGE = "https://www.musicpd.org/libs/libmpdclient/"
5
6inherit meson
7
8SRC_URI = " \
9 git://github.com/MusicPlayerDaemon/libmpdclient \
10"
11SRCREV = "4e8d990eb5239566ee948f1cd79b7248e008620a"
12S = "${WORKDIR}/git"
13
14PACKAGECONFIG ??= "tcp"
15PACKAGECONFIG[tcp] = "-Dtcp=true,-Dtcp=false"
16
17do_install_append() {
18 # libmpdclient's Vala bindings are outdated and unmaintained; it
19 # is likely that nobody will ever use them, so let's not install
20 # them
21 rm -rf ${D}${datadir}/vala
22}