blob: 157e4c91f18e5355a91f19cfcf77dd9711ce6ca9 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "TinyALSA is a small library to interface with ALSA in \
2the Linux kernel. It is a lightweight alternative to libasound."
3HOMEPAGE = "https://github.com/tinyalsa/tinyalsa"
4SECTION = "libs/multimedia"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b"
8
9SRCREV = "67b9210d344c34e8d1aa0cfe638abce71c5221ca"
10SRC_URI = "git://github.com/tinyalsa/tinyalsa"
11PV = "1.1.1+git${SRCPV}"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17# tinyalsa is built as a static library. Enable PIC to avoid relocation
18# errors like these:
19#
20# unresolvable R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `stderr@@GLIBC_2.17'
21CFLAGS += " -fPIC -DPIC "
22
23PACKAGES =+ "${PN}-tools"
24FILES_${PN}-tools = "${bindir}/*"