blob: 947db7836073db1bef7a86e1b1fdf2761b78aa9a [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
2LICENSE = "GPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4
5DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native"
6
7inherit autotools systemd gsettings python3native gtk-icon-cache
8
9SRC_URI = " \
10 git://github.com/blueman-project/blueman.git \
11 file://0001-Search-for-cython3.patch \
12"
13SRCREV = "c4a03417e81e21543d4568e8e7f7de307582eb50"
14PV = "2.0.5+git${SRCPV}"
15S = "${WORKDIR}/git"
16
17EXTRA_OECONF = " \
18 --disable-runtime-deps-check \
19 --disable-schemas-compile \
20"
21
22SYSTEMD_SERVICE_${PN} = "${BPN}-mechanism.service"
23SYSTEMD_AUTO_ENABLE_${PN} = "disable"
24
25RRECOMENDS_${PN} += "adwaita-icon-theme"
26RDEPENDS_${PN} += " \
27 python3-dbus \
28 packagegroup-tools-bluetooth \
29"
30
31PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto,,thunar"
32
33FILES_${PN} += " \
34 ${datadir}/dbus-1 \
35 ${datadir}/Thunar \
36 ${systemd_user_unitdir} \
37 ${exec_prefix}${systemd_system_unitdir} \
38 ${PYTHON_SITEPACKAGES_DIR} \
39"
40
41FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a"