blob: d681f7f30ca01774c1d8c2d5bd17aa0b17883cd6 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Civetweb embedded web server"
2HOMEPAGE = "https://github.com/civetweb/civetweb"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=6f28fdcba0dda735eed62bac6a397562"
6
7SRCREV = "19f31ba8dd8443e86c7028a4b4c37f4b299aa68c"
8PV = "1.10+git${SRCPV}"
9SRC_URI = "git://github.com/civetweb/civetweb.git \
10 file://0001-Unittest-Link-librt-and-libm-using-l-option.patch \
11 file://0001-undefine-macro-before-redefining.patch \
12 "
13
14S = "${WORKDIR}/git"
15
16# civetweb supports building with make or cmake (although cmake lacks few features)
17inherit cmake
18
19# Disable Lua and Duktape because they do not compile from CMake (as of v1.8, v1.9 and v1.10).
20# Disable ASAN as it is included only in Debug build.
21EXTRA_OECMAKE = " \
22 -DBUILD_SHARED_LIBS=ON \
23 -DCIVETWEB_ENABLE_DUKTAPE=OFF \
24 -DCIVETWEB_ENABLE_LUA=OFF \
25 -DCIVETWEB_ENABLE_ASAN=OFF \
26 -DCIVETWEB_BUILD_TESTING=OFF \
27"
28
29# Building with ninja fails on missing third_party/lib/libcheck.a (which
30# should come from external CMake project)
31OECMAKE_GENERATOR = "Unix Makefiles"
32
33PACKAGECONFIG ??= "caching ipv6 server ssl websockets"
34PACKAGECONFIG[caching] = "-DCIVETWEB_DISABLE_CACHING=OFF,-DCIVETWEB_DISABLE_CACHING=ON,"
35PACKAGECONFIG[cgi] = "-DCIVETWEB_DISABLE_CGI=OFF,-DCIVETWEB_DISABLE_CGI=ON,"
36PACKAGECONFIG[cpp] = "-DCIVETWEB_ENABLE_CXX=ON,-DCIVETWEB_ENABLE_CXX=OFF,"
37PACKAGECONFIG[debug] = "-DCIVETWEB_ENABLE_MEMORY_DEBUGGING=ON,-DCIVETWEB_ENABLE_MEMORY_DEBUGGING=OFF,"
38PACKAGECONFIG[ipv6] = "-DCIVETWEB_ENABLE_IPV6=ON,-DCIVETWEB_ENABLE_IPV6=OFF,"
39PACKAGECONFIG[server] = "-DCIVETWEB_INSTALL_EXECUTABLE=ON,-DCIVETWEB_INSTALL_EXECUTABLE=OFF,"
40PACKAGECONFIG[ssl] = "-DCIVETWEB_ENABLE_SSL=ON -DCIVETWEB_SSL_OPENSSL_API_1_1=OFF -DCIVETWEB_ENABLE_SSL_DYNAMIC_LOADING=OFF,-DCIVETWEB_ENABLE_SSL=OFF,openssl (=1.0.2%),"
41PACKAGECONFIG[websockets] = "-DCIVETWEB_ENABLE_WEBSOCKETS=ON,-DCIVETWEB_ENABLE_WEBSOCKETS=OFF,"
42
43BBCLASSEXTEND = "native"