blob: 2b990db3cb8fcbadf5be527ac3766dbd45ea07e8 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Wireless Central Regulatory Domain Database"
2HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA"
3SECTION = "net"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c"
6
7SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz"
8SRC_URI[md5sum] = "0cbbdc21186c76cf58aba01b03f3dc5b"
9SRC_URI[sha256sum] = "e1dfbc3b97771373077f430c3c05082fae883145b37db5b2cfd12c56676fbe7b"
10
11inherit bin_package allarch
12
13do_install() {
14 install -d -m0755 ${D}${nonarch_libdir}/crda
15 install -d -m0755 ${D}${sysconfdir}/wireless-regdb/pubkeys
16 install -m 0644 regulatory.bin ${D}${nonarch_libdir}/crda/regulatory.bin
17 install -m 0644 sforshee.key.pub.pem ${D}${sysconfdir}/wireless-regdb/pubkeys/sforshee.key.pub.pem
18
19 install -m 0644 -D regulatory.db ${D}${nonarch_base_libdir}/firmware/regulatory.db
20 install -m 0644 regulatory.db.p7s ${D}${nonarch_base_libdir}/firmware/regulatory.db.p7s
21}
22
23# Install static regulatory DB in /lib/firmware for kernel to load.
24# This requires Linux kernel >= v4.15.
25# For kernel <= v4.14, inherit the kernel_wireless_regdb.bbclass in kernel's recipe.
26PACKAGES =+ "${PN}-static"
27RCONFLICTS_${PN} = "${PN}-static"
28
29FILES_${PN}-static = " \
30 ${nonarch_base_libdir}/firmware/regulatory.db \
31 ${nonarch_base_libdir}/firmware/regulatory.db.p7s \
32"
33
34# Native users might want to use the source of regulatory DB.
35# This is for example used by Linux kernel <= v4.14 and kernel_wireless_regdb.bbclass.
36do_install_append_class-native() {
37 install -m 0644 -D db.txt ${D}${libdir}/crda/db.txt
38}
39
40RSUGGESTS_${PN} = "crda"
41
42BBCLASSEXTEND = "native"