blob: 8a1bcad28510bd059029fae466dd2c3a88dc2920 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Kernel based automounter for linux"
2SECTION = "utils"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5
6DEPENDS += "libtirpc flex-native bison-native e2fsprogs openssl libxml2 util-linux cyrus-sasl libnsl2"
7
8CFLAGS += "-I${STAGING_INCDIR}/tirpc"
9
10inherit autotools-brokensep systemd update-rc.d pkgconfig
11
12SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
13 file://autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch \
14 file://no-bash.patch \
15 file://cross.patch \
16 file://autofs-5.0.7-do-not-check-for-modprobe.patch \
17 file://fix_disable_ldap.patch \
18 file://autofs-5.0.7-fix-lib-deps.patch \
19 file://add-the-needed-stdarg.h.patch \
20 file://using-pkg-config-to-detect-libxml-2.0-and-krb5.patch \
21 file://force-STRIP-to-emtpy.patch \
22 file://remove-bashism.patch \
23 file://fix-the-YACC-rule-to-fix-a-building-failure.patch \
24 file://0001-Define-__SWORD_TYPE-and-_PATH_NSSWITCH_CONF.patch \
25 file://0002-Replace-__S_IEXEC-with-S_IEXEC.patch \
26 file://pkgconfig-libnsl.patch \
27 file://0001-modules-lookup_multi.c-Replace-__S_IEXEC-with-S_IEXE.patch \
28 file://0001-Do-not-hardcode-path-for-pkg.m4.patch \
29 "
30SRC_URI[md5sum] = "17bc9d371cf39d99f400ebadfc2289bb"
31SRC_URI[sha256sum] = "8d1c9964c8286ccb08262ad47c60bb6343492902def5399fd36d79a0ccb0e718"
32
33UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/"
34
35INITSCRIPT_NAME = "autofs"
36INITSCRIPT_PARAMS = "defaults"
37
38# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
39#CFLAGS += "${LDFLAGS}"
40
41PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd"
42
43PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
44
45EXTRA_OEMAKE = "DONTSTRIP=1"
46EXTRA_OECONF += "--disable-mount-locking \
47 --enable-ignore-busy --with-openldap=no \
48 --with-sasl=no --with-libtirpc \
49 --with-path=${STAGING_BINDIR_NATIVE} \
50 --with-fifodir=${localstatedir}/run \
51 --with-flagdir=${localstatedir}/run \
52"
53CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
54 ac_cv_path_RPCGEN=rpcgen \
55"
56
57do_configure_prepend () {
58 if [ ! -e ${S}/acinclude.m4 ]; then
59 cp ${S}/aclocal.m4 ${S}/acinclude.m4
60 fi
61 cp ${STAGING_DATADIR_NATIVE}/aclocal/pkg.m4 .
62}
63
64do_install_append () {
65 if [ -d ${D}/run ]; then
66 rmdir ${D}/run
67 fi
68 if [ -d ${D}${localstatedir}/run ]; then
69 rmdir ${D}${localstatedir}/run
70 fi
71}
72SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
73
74INSANE_SKIP_${PN} = "dev-so"
75
76RPROVIDES_${PN} += "${PN}-systemd"
77RREPLACES_${PN} += "${PN}-systemd"
78RCONFLICTS_${PN} += "${PN}-systemd"
79SYSTEMD_SERVICE_${PN} = "autofs.service"
80