blob: 31c50ff6b84c42256bac39e91f038ed33b114d74 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "High Availability monitor built upon LVS, VRRP and service pollers"
2DESCRIPTION = "Keepalived is a routing software written in C. The main goal \
3of this project is to provide simple and robust facilities for loadbalancing \
4and high-availability to Linux system and Linux based infrastructures. \
5Loadbalancing framework relies on well-known and widely used Linux Virtual \
6Server (IPVS) kernel module providing Layer4 loadbalancing \
7"
8HOMEPAGE = "http://www.keepalived.org/"
9
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz"
14SRC_URI[md5sum] = "610af6e04071f02d3469191de7499f4e"
15SRC_URI[sha256sum] = "4e2d7cc01a6ee29a3955f5c622d47704ba7d9dd758189f15e9def016a2d1faa3"
16
17DEPENDS = "libnfnetlink openssl"
18
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019inherit autotools pkgconfig systemd
Brad Bishop316dfdd2018-06-25 12:45:53 -040020
21PACKAGECONFIG ??= "libnl snmp \
22 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
23"
24PACKAGECONFIG[libnl] = "--enable-libnl,--disable-libnl,libnl"
25PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
26PACKAGECONFIG[systemd] = "--with-init=systemd --with-systemdsystemunitdir=${systemd_system_unitdir},--with-init=SYSV,systemd"
27
28EXTRA_OECONF = "--disable-libiptc"
29EXTRA_OEMAKE = "initdir=${sysconfdir}/init.d"
30
31do_install_append() {
32 if [ -f ${D}${sysconfdir}/init.d/${BPN} ]; then
33 chmod 0755 ${D}${sysconfdir}/init.d/${BPN}
34 sed -i 's#rc.d/##' ${D}${sysconfdir}/init.d/${BPN}
35 fi
36
37 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
38 install -D -m 0644 ${B}/${BPN}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
39 fi
40}
41
42FILES_${PN} += "${datadir}/snmp/mibs/KEEPALIVED-MIB.txt"
43
Brad Bishop316dfdd2018-06-25 12:45:53 -040044SYSTEMD_SERVICE_${PN} = "keepalived.service"
45SYSTEMD_AUTO_ENABLE ?= "disable"