blob: d236714325433db638e08afb15dbf7fc798bef25 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A high performance, open source, general-purpose RPC framework. \
2Provides gRPC libraries for multiple languages written on top of shared C core library \
3(C++, Node.js, Python, Ruby, Objective-C, PHP, C#)"
4HOMEPAGE = "https://github.com/grpc/grpc"
5SECTION = "libs"
6LICENSE = "Apache-2"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
8
9DEPENDS = "gflags c-ares protobuf protobuf-native protobuf-c protobuf-c-native openssl"
10DEPENDS_append_class-target = " gtest grpc-native "
11DEPENDS_append_class-nativesdk = " grpc-native "
12
13S = "${WORKDIR}/git"
14SRCREV = "d8020cb6daa87f1a3bb3b0c299bc081c4a3de1e8"
15BRANCH = "v1.14.x"
16SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;branch=${BRANCH} \
17 file://0001-CMakeLists.txt-Fix-libraries-installation-for-Linux.patch \
18 "
19SRC_URI_append_class-target = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch"
20SRC_URI_append_class-nativesdk = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch"
21
22# Fixes build with older compilers 4.8 especially on ubuntu 14.04
23CXXFLAGS_append_class-native = " -Wl,--no-as-needed"
24
25inherit cmake
26
27EXTRA_OECMAKE = " \
28 -DgRPC_CARES_PROVIDER=package \
29 -DgRPC_ZLIB_PROVIDER=package \
30 -DgRPC_SSL_PROVIDER=package \
31 -DgRPC_PROTOBUF_PROVIDER=package \
32 -DgRPC_GFLAGS_PROVIDER=package \
33 -DgRPC_INSTALL=ON \
34 -DCMAKE_CROSSCOMPILING=ON \
35 -DBUILD_SHARED_LIBS=ON \
36 "
37
38BBCLASSEXTEND = "native nativesdk"
39
40SYSROOT_DIRS_BLACKLIST_append_class-target = "${libdir}/cmake/grpc"
41
42FILES_${PN}-dev += "${bindir}"