blob: 725ba189c6c0b865c3c113855961e4378372d8f7 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Libraries and wrapper for using a SOCKS proxy"
2DESCRIPTION = "The role of tsocks is to allow non SOCKS aware \
3applications (e.g telnet, ssh, ftp etc) to use SOCKS without any \
4modification. It does this by intercepting the calls that applications \
5make to establish network connections and negotating them through a \
6SOCKS server as necessary."
7HOMEPAGE = "http://sourceforge.net/projects/tsocks/"
8SECTION = "net"
9LICENSE = "GPL-2.0"
10LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
11
Patrick Williamsddad1a12017-02-23 20:36:32 -060012SRC_URI = "http://downloads.sourceforge.net/tsocks/tsocks-${PV}.tar.gz \
13 file://makefile-add-ldflags.patch \
14 "
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015
16SRC_URI[md5sum] = "51caefd77e5d440d0bbd6443db4fc0f8"
17SRC_URI[sha256sum] = "849d7ef5af80d03e76cc05ed9fb8fa2bcc2b724b51ebfd1b6be11c7863f5b347"
18
19inherit autotools-brokensep
20
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021LIBS_append_libc-musl = " -lssp_nonshared"
22LIBS_append_libc-glibc = " -lc_nonshared"
23
Patrick Williamsb48b7b42016-08-17 15:04:38 -050024S = "${WORKDIR}/tsocks-1.8"
25
26FILES_${PN} = "${libdir}/* ${bindir}/tsocks"
27FILES_${PN}-dev = ""
28INSANE_SKIP_${PN} = "dev-so"
Brad Bishop7f28bc52017-12-03 23:42:40 -050029
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030EXTRA_OEMAKE = "SHCC='${CC} -fPIC ${LDFLAGS}' LIBS='${LIBS}'"
Brad Bishop7f28bc52017-12-03 23:42:40 -050031